Firefox Tweak Guide
This section covers all the main Firefox settings which can be accessed under
the Firefox options menus. Before you do any customization or tweaking of
Firefox, you need to understand what all of these settings do, and make sure that
they are configured correctly for your machine.

The main Firefox settings can be found by going to the Tools menu and selecting
Options. Each section of the Options window is covered in detail below, with my
recommendations where relevant:

Main

When Firefox starts: Whenever you launch Firefox, you can configure it to do one
of the following: 'Show my home page' will load up the home page you set in the
Home Page option.'Show a blank page' will simply start Firefox with a blank
page; and the 'Show my windows and tabs from last time' option' will use Firefox
2.0's new Session Restore feature to restore all your open browser windows/tabs
to exactly the way they were when you last closed Firefox. Select the option you

prefer, but obviously the more pages Firefox has to load when starting up, the
slower startup may be.

Home Page: If you've chosen the 'Show my home page' option under the When
Firefox Starts setting (see above), you can set the home page which appears
whenever you open up Firefox. You can either manually enter a web address in
the Locations box; if you want to set the page you are currently viewing as the
home page click the 'Use Current Page' button; or you can choose a page from
your Bookmarks. You can set multiple homepages as well, each opening up in a
separate tab when you launch Firefox or click the Home button - see the
Customizing Firefox section.

Downloads: When Firefox begins downloading a file using its built-in download
manager, and the 'Show the Downloads window when downloading a file' box is
ticked, you will see the Download Manager window appear. This is useful as it
shows you the progress of the file download, and gives you the option of
cancelling the download at any time - hence I recommend you tick this option. I
suggest you also tick the 'Close it when all downloads are finished' box so that
when all downloads are completed the download manager box automatically
disappears as well.

Save Files To: Every time you choose to download a file from the Internet with
Firefox, the download manager will save it to a particular location. You can either
select to have Firefox 'Ask me where to save files' for each file, or as I
recommend, select a fixed download folder under the 'Save all files to this folder'
box. Note: I don't recommend saving files to Desktop, as this can increase
Memory usage in Windows.

System Defaults: Whenever you click on a hyperlink in an email, document or
PDF file Windows uses your 'default browser' to view the web page. On Windows
this is always Internet Explorer unless otherwise specified. The 'Always check to
see if Firefox is the default browser on startup' option if ticked allows Firefox to
check whether it is the default browser each time it starts, and set itself as such if
it is not. You should untick this option by default for fastest startup, and instead if
you want Firefox to be the default browser, go to your Windows Control
Panel>Add/Remove Programs. On the left hand side of the 'Add or Remove
Programs' box, click the 'Set Program Access and Defaults' icon. Select the
Custom option, and under the 'Choose a default web browser' section select

'Mozilla Firefox'. However make sure you also tick the 'Enable access to this
program' box next to Internet Explorer - you need to use Internet Explorer to run
the Windows Update feature for example, not to mention that some other pages
may not open and/or view correctly with Firefox. Click OK to close, and now
Firefox is your default browser. To confirm this, click the 'Check Now' button.

Next, go into Internet Explorer, and under the Tools menu select 'Internet
Options'. Under the Programs tab, at the very bottom of the box untick the
'Internet Explorer should check...' or 'Tell me if Internet Explorer is not...' box so
that Internet Explorer doesn't nag about this or switch itself back to being the
default browser each time you run it.

Tabs

New pages should be opened in: This setting essentially controls whether you
use tabbed browsing or not. It comes into effect any time you launch a new web
page, whether from within Firefox, or when clicking on a web link in an
application, email or game. There are two simple options: selecting 'a new
window' means that all new pages launched will open as a new window in a
separate instance of Firefox; the 'a new tab' option means that if Firefox is
already running, any new pages launched will open as a new tab within an
existing instance of Firefox. I strongly recommend the 'a new tab' option to take
advantage of tabbed browsing in Firefox, and prevent lots of instances of Firefox
running.

Warn me when closing multiple tabs: If ticked, this option raises a warning when
you try to close a Firefox window containing multiple open tabs. If you're the
forgetful type, or if you're used to using Internet Explorer and perhaps expect
each page to be open in a separate window, you might want to tick this.
Otherwise for most people I suggest unticking it for quicker closing of Firefox
windows.

Warn me when opening multiple tabs may slow down Firefox: If ticked, Firefox
will warn you if you are likely to cause slowdowns or problems in Firefox by
launching too many tabs at once. For the most part this depends on how much
memory your system has available. I suggest ticking it to begin with, as you

shouldn't be warned unless you're truly getting to the point where there are too
many tabs open and Firefox is using too much memory to remain responsive. At
this point obviously the best option would be to close Firefox altogether and reopen it with fewer tabs.

Always show the tab bar: If ticked, this option forces the tab bar at the top of the
Firefox viewable browser area to remain shown, even if only one page is
currently open. If more than one tab is open, this option has no impact - the tab
bar will be displayed anyway. I suggest you untick this option, as there is not
much use for a tab bar if only one page is being displayed.

When I open a link in a new tab, switch to it immediately: This option determines
whether pages launched in a new tab are shown in the foreground or the
background. When you open a new tab from a link on the current page, if this
option is unticked any new tabs opened will be in the background, not affecting
the tab you're currently viewing. If ticked, your view will automatically switch to
the most recently opened tab, effectively forcing all other tabs to the background.

Content

Block pop-up windows: This option should remain ticked, as it blocks 'popup'
windows. Popups are separate browser windows which typically open up by
themselves after you open a web page. They are most commonly used for
advertising, and can vary in size and location on the screen, as well as
frequency. However there are some sites which have legitimate popup windows
(such as Internet Banking sites or Internet forums), and hence won't work
correctly with this setting ticked. If you experience problems with such a site, click
the 'Exceptions' button and enter the name of the site you want to allow popups
for in the form www.sitename.com, then click the Allow button. Note that some
spyware can also launch popups, regardless of the site you visit, so make sure
you scan your system for such malicious software .Note further that some
popups are actually launched when you click on a particular field or area of a
web page, and are specially designed to circumvent popping blocker. You can
only block such popups if you disable Javascript for example, or install the
NoScript extension.

Load images automatically: I recommend you tick this option, as it allows images
to be loaded with web pages. Since most web pages contain images, unticking
this option would see all the sites you visit devoid of any imagery. If however you
want to choose to disable or allow images specifically on a website-by-website
basis, you can click the Exceptions button and manually select websites which
you can then permanently Block or Allow images from separately. Just remember
that most graphical advertisements are actually Flash files or scripts, and not
simple images, and hence this setting doesn't affect them. See the Extensions &
Themes and Advanced Tweaking sections for details of how to block different
types of ads.

Enable Javascript: Many sites use Javascript to produce certain effects, display
certain information or allow a range of functionality. If this option is ticked, such
sites will function correctly when viewed with Firefox. For that reason I
recommend you leave this option ticked, as many websites will not display or
function correctly without it. Click the Advanced button to see the types of
Javascript tricks which you can disable. Here you can disable the more annoying
effects. For example, I personally have all the functions listed unticked - this
means all websites display correctly however they can't try any fancy tricks like
resizing windows on me or hiding my toolbars. If you want to be more selective
about which sites you allow to run Javascript on, see the Extensions & Themes
section.

Enable Java: Java is a programming language which allows a range of
functionality on websites. If this option is ticked, sites which require Java will
usually prompt you to install the Java software if you don't already have it
installed for Firefox. By default Firefox does not come with Java installed - this is
because some people do not prefer their browsers to be Java-enabled. If you do
want to install Java, then go here to download the latest version. Aside from
downloading Java you have two other options: you can view the site with Internet
Explorer which may already have MS Java Virtual Machine support built into it or
you can simply ignore the requirement for Java and view the site "as is". You
don't have to enable or install Java if you don't want to, as it is not vital, but it will
reduce or impair important functionality on certain sites.

Fonts & Colors: As part of customizing Firefox, you can select the fonts, colors
and styles used for various elements of web pages displayed in Firefox. For
example, if you want all Sans-serif text on web pages to be Arial, click the
Advanced button then select that font under the 'Sans-serif' box. You can even

set a minimum font size. You can also change the colors used for various text
and links on web pages by clicking the Colors button.

The important thing to understand is that most web pages already specify their
default fonts and the styles of various elements like hyperlinks, background and
text colors, etc. Therefore changing the settings here will typically have no visible
impact. If you want your selections here to override the default web page options
you have to untick the relevant 'Allow pages to choose their own...' boxes in the
Advanced and/or Colors sections. For example, in the Advanced section, alter
the fonts and sizes as required, then untick the 'Allow pages to choose their own
fonts, instead of my selections above' box, then click OK to close this screen, and
OK again to close the options. Refresh the current web page you are viewing and
it will have changed to reflect the font and color choices you have made. Clearly
most web pages are designed around their own font and color settings and you
shouldn't override them if you want to view them correctly. However with a bit of
testing you may happen upon a better combination of fonts and colors which
work with all websites to better suit your tastes and/or needs.

File Types: The first time you click on certain types of files you will be asked
whether you want to save them to disk, or open them, and whether you want
your choice to become the default behavior for each time you click on that
particular file type. Your choices are stored in this section of the Options. Click
the Manage button and for each file type you have clicked on so far, as well as
for a range of default file types, you will see an associated default action. If you
want to change any of these, highlight the file type, and you can click on the
'Change Action' button to change the action, and where applicable, you can also
click the 'Remove Action' to remove non-default file type actions. To change file
actions in the Change Actions dialog box, you can select the application which
opens that file type by default, and whether Firefox should open the file or save it
to your computer by default whenever you click on a link of that type in Firefox.

In particular I recommend that you change the behavior for .zip, .rar, .pdf and
.doc file types to 'Save them to my computer' here, as these file types usually try
to automatically open up within Firefox, and most commonly you would want to
save these files to disk rather than having them open up within the browser.
Adobe PDF file links for example can take quite a while to load up if Firefox
attempts to open them within the browser instead of saving them to disk. Again,
make sure to save them somewhere other than the Desktop for memory usage
reasons.
Security

Warn me when sites try to install add-ons: I recommend you tick this option as it prevents
websites from installing harmful or malicious add-ons without your knowledge (See the
Extensions & Themes section). Click the 'Exceptions' button to view the sites which are allowed
to install Firefox extensions and themes without warning - by default there are two official Mozilla
sites for allowing you to download and install approved Extensions and Themes for customizing
Firefox - addons.mozilla.org and update.mozilla.org. You should leave these here, however if
other untrusted or unknown sites are listed here, highlight them and remove them.
Note: the most commonly used software you will need installed when viewing websites is Java
(See the Enable Java setting on the previous page) and Flash - which you can download and
install directly from Adobe. For other common plugins for Firefox, go to the Firefox Plugins secure
page. For more details of how to install other software for Firefox and where to get it see the
Extensions & Themes section in this guide.
Tell me if the site I'm visiting is a suspected forgery: This setting is part of Firefox's new Phishing
Protection feature. It is strongly recommend enabling this option, as it adds another layer of
protection against having your important data (such as bank account details) stolen. You can
select the method the phishing protection uses: either 'Check using a downloaded list of
suspected sites' which is reasonably reliable and has no privacy or performance impact, but
doesn't protect you against very recent phishing sites; or 'Check by asking Google about each
site I visit' which allows Firefox to use its new built-in Google Safe Browsing capabilities to identify
suspicious sites.
In general the choice is yours, so long as you use one of the options and don't disable the antiphishing featuers altogether. The advantages of using the Google option are that it provides
better protection against a wider range of sites, since it is always kept up to date; the
disadvantages are that it may add slightly to page load times, and also has privacy impacts, since
the URL of every page you view is sent to Google first to check before being viewed. If you need
greater security, click the second option, if you value performance and privacy over security, click
the first option.
Passwords: If the 'Remember passwords for sites' box is ticked, whenever you enter a username
and password on a web page, you will be given the option to record that username/password
combination. The next time you go to the same site your username will automatically be filled in,
and the password will also be filled in as a series of *****. This speeds up logging into sites,
however it is obviously a security threat if you share the computer, so untick this option if security
is the major concern.
To view the currently stored usernames and passwords (and the sites they relate to), click the
'Show Passwords' button. This opens a box which shows every combination of
username/password you've entered on a particular site. To view the actual passwords for each
username, click the 'Show Passwords' button at the bottom of the box. You can highlight and
Remove all incorrect or unnecessary username/password combinations as required. If you want
to protect yourself from other users who may view your password list, click the 'Use a master
password' option and then enter a master password. Note that the more letters and numbers the
password contains, the stronger it will be as indicated by the password quality meter at the
bottom of the master password dialog box. Now whenever you click the Show Passwords button
you will have to enter this master password to gain access.
Warning messages: As you use Firefox in a variety of situations you may see a range of warning
messages which state obvious but important facts. You can disable these messages at the time
they're shown, or you can click the Settings button here and tick/untick which messages you want
shown on a regular basis. For the most part none of these warnings is absolutely vital and can be
unticked as long as you're vigilant about your general browsing.

Basic Tips & Tweaks

This section covers some basic yet important tips and tricks you can try to make using Firefox
more convenient. Beginner users should definitely not skip this section, but even Advanced users
who may already be aware of the majority of these might find some tips theey haven't yet seen.

Streamlined Firefox Layout

To provide maximum viewable space in the Firefox browser window, many people use a
streamlined Firefox layout which I will detail here. The difference between the default and the
streamlined view is shown below:

As you can see, the streamlined view retains all the main functionality of Firefox, but reconfigures
the layout to be as minimal as possible. Follow these steps to implement it:
1. Open Firefox, go to the View menu, select Toolbars and untick the 'Bookmarks Toolbar' item.
2. If you have a Sidebar showing, under the View menu select Sidebar and unselect any items.
3. Under the View menu select Toolbars and then select Customize. Alternatively you can rightclick on an empty spot on a toolbar and select Customize.
4. In the 'Customize Toolbar' box which appears, select Icons in the Show box (not 'Icons and
Text', or Text). If you're running a lower screen resolution also tick the 'Use Small Icons' box.
5. Now remove every icon or element in the Firefox toolbar at the top of the browser which you
don’t need. For example, drag and drop the Search box into the 'Customize Toolbar' box to

remove it from the Firefox toolbar. Do the same for any other icons/elements which you feel are
unnecessary, such as the large white space filler at the top right of the Navigation toolbar. You
can always re-add these elements at any time if you change your mind later on.
6. Now drag and drop each icon in the bottom Firefox toolbar up to the top toolbar, just to the right
of the 'Help' menu item. This includes the large white Address box. The aim is to have everything
on a single toolbar.
7. Insert any additional icons, separators or blank spaces you need from the selection shown in
the 'Customize Toolbar' box into the relevant spots on the top Firefox toolbar. When finished, click
the Done button.
8. Finally, go to the View menu, and under Toolbars unselect the 'Navigation Toolbar' as it should
now be completely empty anyway.
You should now have a single Firefox toolbar at the top of your browser, complete with all the
menu commands, relevant icons and the address box. This gives you more vertical viewable
space (and a substantial amount of horizontal space if you had a sidebar showing). If you need
more, go to the View menu and untick the 'Status Bar' item as it is not vital, and provides a further
bit of vertical viewable space.

Obviously this layout may not suit everyone, and can be modified to suit your taste. However
once you get used to it, it is extremely efficient and provides maximum viewable space in Firefox.
Note that you can further customize the layout by looking under the Advanced Tweaking section.
Tabbed Browsing
The most famous features of Firefox is Tabbed Browsing. This is a feature which allows users to
open up a link as a new tab within their current Firefox window, rather than opening up an entirely
new Firefox window. The benefits of this are faster loadup times for pages opened as tabs, less
overall system memory usage, less buttons for open instances of Firefox on the Windows
Taskbar, the ability to load pages in the background while reading the current page, and the
convenience of being able to switch back and forth between pages just by clicking their tab.

Opening, Closing and Switching Tabs: Whether you use tabbed browsing or not is up to you,
however it is generally recommended that you do, and there are some basic things you can do to
make better use of this feature:

• To open any link as a new tab you simply need to click your center mouse button while pointing
to a link. If you don't have a center mouse button, hold down the CTRL key then left-click on a link
to get the same result.
• If you want to force a link to open as a new tab in the foreground, you need to hold down the
SHIFT key and use the relevant methods above.

• If you want to close a tab quickly, simply click the center mouse button on the tab, or press
CTRL + W or CTRL + F4 while viewing the tab. Or you can just click on the red 'X' on the tab
itself.
• To switch quickly between open tabs, press CTRL + Tab Key to go to the next open tab, or
SHIFT + CTRL + TAB Key to go to the previous open tab.
• If you want to go to a specific open tab, press CTRL and a number key corresponding to that
tabs position from the left. For example, pressing CTRL + 2 will jump to the second open tab.
• You can rearrange the order of open tabs by dragging and dropping them.

In fact, if you click your middle mouse button on a range of things in Firefox, they will typically
open up in a new tab (substitute CTRL for middle-click). For example, click the middle button on
the back or forward arrows at the top of Firefox, and the previous or next pages you've visited will
open in a new tab. Middle-click on an item in your history or your Bookmarks and it will open in a
new tab. Middle-click on the Homepage toolbar icon and your home page will open in a new tab.

Note that as of Firefox 2.0, once a certain number of tabs are opened, the tabs start to shrink in
width and at a certain point no more tabs will be shown on screen. Instead a small dropdown
button at the far right of the tab bar can be clicked to show a listing of all open tabs. For more
ways of customizing tabs and tabbed browsing see the browser.tabs.-related preferences in the
Advanced Tweaking section.

Faster Searching

There are several ways you can speed up searching web pages and searching on the Internet
using Firefox:

Search for text when I start typing: I recommend that you have the 'Search for text when I start
typing' setting ticked (See the Settings section above). That way you can initiate a word search
on the currently viewed web page simply by starting to type the search string on your keyboard
without having to first bring up the search box. The first instance of that word will automatically be
highlighted in green on the page. To find more instances of the word(s), keep pressing the F3
key. Note that the last search string you entered is kept in memory, and simply pressing F3 on
any other page initiates the same search again. Pressing ESC closes the search box, but it also
closes automatically if you click anywhere else in the Firefox window. For more ways of
customising this function, see the accessibility.typeaheadfind.-related preferences in the
Advanced Tweaking section.

Keyboard Shortcuts: Another way to quickly open the search box is to use the keyboard shortcuts
F3 or CTRL+F. You can quickly close the search box by pressing the ESC key at any time.

Selection Web Search: Highlight a portion of a web page by holding down the cursor over the
start of your selection, then left-click and drag the cursor to the end of your selection and release
the mouse button. Now right-click on this highlighted selection, and in the context menu select the
'Search Google for...' item. Firefox will automatically launch a web search using your the default
search plugin Google and provide the results in a new tab/window.

Web Search Box: You can use the dedicated Web Search box in your Firefox toolbar to speed up
searching for information on the Internet. If it isn’t already there, to add it in go to
View>Toolbars>Customize and in the 'Customize Toolbars' box find the white Search box, and
drag and drop it into a suitable position on your Firefox toolbar, then click Done. Next, click on the
small icon in the left side of the search box, and select the search engine you wish to use for web
searches - Google is the default and recommended engine, although you can use a more specific
site such as Answers.com or Ebay.com for example. Now enter the phrase(s) you wish to search
for in this Search box and press Enter - the results will be displayed in the main Firefox browser
window.

Note that as of Firefox 2.0, the search box also has search completion on by default. This means
that as soon as you start typing a search phrase into the box, suggested variations will appear in
a drop box below it. You can then select any of these variations if you wish to search for that
phrase, or continue to finish what you were typing. If you don't like this feature, right-click in the
search box and unselect 'Show Suggestions'.

You can download additional plugins for the Web Search box by clicking on the Search icon next
to the Search box, selecting 'Manage Search Engines' and then clicking the Get more search
engines link at the bottom. . You can also create your own custom search. Since all the search
engine coding is saved in your \Program Files\Mozilla Firefox\searchplugins\ directory as .xml
files, you can create your own .xml file which will allow you to use the Search box to launch a
search on any site you wish.

Address Bar/Keyword Searches: One of the fastest ways to search is by using keywords within
the Firefox address bar. By default if you enter a word in the Firefox address bar it will attempt to
find the closest matching web page for that word (using Google's 'I'm Feeling Lucky' search by
default) and open up the site. If you want to add the Web Search functionality (covered above)
directly to the Address bar, simply right-click in any search box on a web page and select 'Add a
keyword for this search'. Note you can jump to the address bar quickly at any time by pressing
CTRL+L. This moves the cursor to the address bar and highlights all existing text in there.

Further ways to customize searching behavior are in the Advanced Tweaking section of the
guide.

Always Viewing the Latest Content

Force Reload: By default Firefox does not automatically re-download the entire contents of a web
page every single time you visit the page. It will first try to detect if the page content has changed
significantly from any stored versions of the same page it holds in your browser cache. This is
fine since most websites don't change their content every minute or even every hour. However
often webmasters may change small parts of the site, update only a tiny portion of a page, or
even one or two important words in the text body, and Firefox will not show the updated page for
a day or two. For example I regularly update my guides on TweakGuides.com and users write to
me saying they still only see the old version. To remedy this, there is a simple way you can make
sure Firefox loads up the latest version of a web page at any time: simply press CTRL+F5, or
hold down the SHIFT key and left-click on the Reload icon. This forces Firefox to reload every
part of the currently viewed page from the Net and not your cache, ensuring every part of the
content you're viewing is the latest available. Use this method at any time if you believe you are
viewing an old version of a page.
See the Advanced Tweaking section for more details of how to change this Firefox behavior
permanently for every web page viewed.
Spell Checker

One of the prominent new features in Firefox 2.0 is the integration of a spell checker. This might
seem confusing at first, however the aim of the spell checker isn't to check the spelling on web
pages you're viewing, it's to check the spelling of any text boxes in which you can enter text. For
example, if you're posting on a Forum, or entering text into an online form or search box, by
enabling the spell checker ('Check my spelling as I type' option found under
Tools>Options>Advanced>General>) any spelling mistakes you make will be underlined in red.
Right-clicking on these underlined items will show you suggested alternative spellings which you
can click on to use instead, or if the word is correct, you can ignore the spell check, or select 'Add
to Dictionary' and it will be stored and not flagged as being misspelled in the future.

Some text entry boxes however do not have spell checking enabled by default. To enable spell
checking in any text entry box on a web page temporarily, right-click in the box and select 'Spell
check this field'. To enable spell checking in all text boxes permanently, see the
Layout.spellcheckDefault preference in the Advanced Tweaking section. Furthermore, ideally you
should have downloaded the correct language version of Firefox for your region (see page 3), as
this affects the specific dictionary that Firefox uses by default. For example if you downloaded the
English US version of Firefox and you live in Australia, it will falsely pick up some Australian
spellings as incorrect. Furthermore dictionaries for certain regions are not automaticaly built into
Firefox. To add new dictionaries to your existing version of Firefox, right-click in a spell-checked
field and select Languages>Add Dictionaries. You can then install a new dictionary, and select
which to use under the Languages menu item in the spell checker.

The spell checker generally does not affect performance, however note that on pages which have
editable text boxes containing a very large amount of text, this can cause a slowdown as Firefox
checks for errors. To reduce this problem see the extensions.spellcheck.inline.max-misspellings
preference in the Advanced Tweaking section. In general though there should be no real reason
to ever disable the spell checker.

Bookmarking
• Your bookmarks are web pages whose URL addresses you have stored so that you can return
to these pages quickly and easily just by clicking on their bookmarks. This is identical to the
Favorites feature in Internet Explorer. However there are some neat things you can do in Firefox
to make your bookmarks far more useful.Sorting Bookmarks: To quickly sort your bookmarks at
any time, go to the Bookmarks menu of Firefox, right-click anywhere on your list of bookmarks
and select 'Sort By Name' - they will be alphabetically sorted by the name of the bookmark, with
folders first, and standalone bookmarks below them. You may have to do the same thing again
for the contents of each folder.

Keywords: To start with, if you want to rapidly access your bookmarks, go to the Bookmarks
menu, right-click on the bookmark and select Properties. In the Properties box which opens, you
can assign a shortcut to this bookmark in the Keyword box. For example, if you have
TweakGuides.com bookmarked, enter "t" (without quotes) in the Keyword box, and click OK to
close the box. Now the next time you want to quickly load up TweakGuides.com, go to the
address bar and simply type the letter "t" (without quotes) and press Enter - the
TweakGuides.com front page will load up straight away. You can assign custom keywords whether a single letter or an entire word - to each of your favorite bookmarks and use them in the
address bar in a similar way. If you assign a Keyword to a search engine search result, you can
use it to speed up searches as well - see the Faster Searching tips above for details.

Bookmarking Multiple Tabs: If you want to quickly bookmark several open tabbed pages, open all
the tabs you want to bookmark, then go to the Bookmarks menu in Firefox and select 'Bookmark
all tabs', and give the new folder a name. The next time you want to open all the sites listed in the
folder, go to that bookmarked folder, right-click on it and select 'Open all tabs'.

Live Bookmarks: If you visit websites which have RSS feeds, such as news and blog sites, you
can bookmark them as 'live' bookmarks. To do this, just click on the orange RSS icon in the
bottom right of your Firefox window (note: you must have the Status Bar visible to see this icon).
From there, you can select the type of RSS subscription, and the bookmark will be added with a
sub-folder which has all the latest articles from that site as a live feed. By default Firefox 2.0 has
one such bookmark under the 'Latest Headlines' folder.

Bookmark Add-ons: If you want to do more with Bookmarks, go to your Bookmark menu and
select the Get Bookmark Add-ons item.

There are further tips to improve bookmarks in the Advanced Tweaking section.
Clear Private DataThis feature of Firefox is covered in the Firefox Settings section of this guide,
however basically it allows you to quickly remove a range of personal data from the browser in

one go. Again, for more details of how to configure it, see the Firefox Settings section on the
previous pages. Aside from accessing it from within the Firefox Options, you can also access it on
your Firefox menu, under Tools>'Clear Private Data', or by clicking CTRL+SHIFT+DEL together.
If you use this function often, untick the 'Ask me before clearing private data' box. Now whenever
you use the menu option or press the keyboard shortcut for this function, it will occur instantly
without asking you to confirm any options. If you want to automatically clear relevant private data
each time you close Firefox, that too is possible if the 'Always clear my private data when I close
Firefox' option is ticked in the Firefox Options screen.

